首页 > 软件和应用 > 常用软件教程 > v2ray – 性能优异的模块化代理软件
2016
09-16

v2ray – 性能优异的模块化代理软件

生命不息,折腾不止!今天给大家带来的是一款叫做 v2ray 的代理软件。老早就听群友们推荐这款代理软件了,但是由于平时上班,也抽不出时间来看这个软件。趁着中秋放假,稍微试了试,结果确实惊艳到我了!

这是个比较小众的软件,小众但是并不代表它不好用。代理速度,是我们选择一款软件的首要条件,下面是网上一篇帖子:四(三)大开源代理技术测速 仅供参考。而我的实际测试速度也确是如此,而且该软件兼容 Shadowsocks 协议,这意味着,你可以使用 Shadowsocks 客户端来连接它,而不必安装其他的客户端软件,简直是 Shadowsocks 的完美替代品。

官方网站:https://www.v2ray.com

服务端安装

官方已经把一键安装脚本写好了,所以安装 v2ray 非常简单:

等待片刻即安装完毕。然后可以启动 v2ray:

下面可以开始配置了,由于 json 格式不支持注释,下面的所有的注释只做说明使用,请不要将注释添加到你的配置文件中。

使用 v2ray 原版协议

1.服务端配置

然后我们需要修改服务端的配置文件,这是一个 json 文件

文件打开之后你只需要看开头这部分:

你可以随意修改端口,如果想要修改 ID,可以访问这个网站生成:https://www.uuidgenerator.net/

修改完成之后重新启动 v2ray:

2.客户端配置

首先需要下载客户端软件:https://github.com/v2ray/v2ray-core/releases

例如我是 Windows 64位,可以下载 v2ray-windows-64.zip

然后下载客户端启动软件:https://www.v2ray.com/chapter_01/3rd_party.html

Windows 可以下载 v2ray-taskbar:

https://github.com/kxjhlele/v2ray-taskbar/releases/download/0.2/v2ray-taskbar.zip

将以上两个压缩文件解压到同一文件夹下:

v2ray - 性能优异的模块化代理软件 - 第1张  | 扩软博客

打开 config.json 开始来配置客户端:

默认使用的是 SOCKS 协议,它的说明可以看这里:https://www.v2ray.com/chapter_02/protocols/socks.html

配置完毕之后,双击 v2ray-taskbar.exe 启动,以下为日志:

然后可以配置代理了,比如我在 Chrome 上配置 SwitchyOmega:

v2ray - 性能优异的模块化代理软件 - 第2张  | 扩软博客

需要自动切换的请自行配置。然后将代理切换至 v2ray,尝试访问,配置完毕!

使用 Shadowsocks 协议

v2ray 兼容 Shadowsocks 协议,配置好之后相当于你多了一个 Shadowsocks 服务端。

1.服务端配置

依旧打开配置文件:

文件的默认协议部分可以保留,然后在 inbound 后面加入扩展配置( 注意: 请自行删除注释说明 ):

在配置文件中,我开了两个兼容 Shadowsocks 的端口,分别是 30001 和 30002。其他说明可以看这个页面:

https://www.v2ray.com/chapter_02/protocols/shadowsocks.html

重启 v2ray 服务端:

2.客户端配置

客户端直接使用 Shadowsocks 或者 ShadowsocksR 的客户端。

v2ray - 性能优异的模块化代理软件 - 第3张  | 扩软博客

所有配置完毕,将 Shadowsocks 代理切换到该服务器上,测试。

最后编辑:
作者:
百度ID:“度娘程序员”,博主。
捐 赠如果您觉得这篇文章有用处,请支持作者!鼓励作者写出更好更多的文章!

v2ray – 性能优异的模块化代理软件》有 16 条评论

  1. Google Chrome 62.0.3202.89Google Chrome 62.0.3202.89Windows 10 x64Windows 10 x64

    VMess协议怎么使用chacha20加密

  2. Google Chrome 60.0.3112.113Google Chrome 60.0.3112.113Windows 7 x64Windows 7 x64

    ovz下开启bbr造成vr代理故障。删掉bbr变正常。没有bbr测试下 速度差ssrbbr很多条街。最大的缺点是没有自动代理各种麻烦。更不用说pac这类判断功能。结论vr没有ss高速方便

  3. Google Chrome 58.0.3029.110Google Chrome 58.0.3029.110Windows 10 x64Windows 10 x64

    博主,请问在已安装并使用shadowsocksr+BBR LKL和kcptun的情况下,可以再安装使用V2RAY吗

  4. Vivaldi 1.8.770.56Vivaldi 1.8.770.56GNU/Linux x64GNU/Linux x64

    额,很好用,就是配置有些麻烦

  5. Google Chrome 55.0.2883.87Google Chrome 55.0.2883.87Windows 7 x64Windows 7 x64

    纯小白在搬瓦工Ubuntu 12.04 x86 上部署,
    到./install-release.sh的时候提示
    ./install-release.sh: line 90: curl: command not found
    ./install-release.sh: line 91: /usr/bin/v2ray/v2ray: No such file or directory
    Lastest version is already installed. Exiting…
    求破。。。

  6. Google Chrome 53.0.2785.116Google Chrome 53.0.2785.116Windows 10 x64Windows 10 x64

    ”invalid character ‘.’ looking for beginning of object key string“
    启动V2ray电脑和手机客户端的时候都出现这句话,请问怎么解决?
    谢谢

  7. Google Chrome 52.0.2743.116Google Chrome 52.0.2743.116Windows 7 x64Windows 7 x64

    “目前自动运行脚本只支持带有 Systemd 的系统,以及 Debian / Ubuntu 全系列。” 大神能否写一个支持systemV的?

  8. Google Chrome 52.0.2743.116Google Chrome 52.0.2743.116Windows 7 x64Windows 7 x64

    提示 /etc/init.d/v2ray 里有多个命令找不到,不仅是29行。。

    • Google Chrome 55.0.2859.0Google Chrome 55.0.2859.0Windows 10 x64Windows 10 x64

      官方脚本估计没有完全支持 Centos6 用 Debian 或者 Ubuntu 吧

  9. Firefox 48.0Firefox 48.0Windows 10 x64Windows 10 x64

    前段时间试了一下 v2ray+mKCP 比 Shadowsocks+kcptun 慢很多,就放弃了。

    • Google Chrome 50.0.2661.102Google Chrome 50.0.2661.102Windows 10 x64Windows 10 x64

      是的,慢太多了,作者现在一直在加一些乱七八糟没什么人用的功能,不肯花精力搞好kcp优化速度。

    • Google Chrome 54.0.2840.99Google Chrome 54.0.2840.99Windows 7 x64Windows 7 x64

      可以試試不用 v2ray內置kcp

  10. Firefox 48.0Firefox 48.0Windows 8 x64Windows 8 x64

    大神,centeos的系统按你的service v2ray start这个命令提示/etc/init.d/v2ray: line 29: /lib/init/vars.sh: No such file or directory,服务器端没法启动
    liunx小白。。。不懂正确的语法

    • Google Chrome 55.0.2859.0Google Chrome 55.0.2859.0Windows 10 x64Windows 10 x64

      你是 CentOS7 么?用 systemctl v2ray restart 试试

      • Firefox 48.0Firefox 48.0Windows 8 x64Windows 8 x64

        用的centos6
        目前自动运行脚本只支持带有 Systems 的系统,以及 Debian / Ubuntu 全系列。
        作者这样介绍的。。而且我一键安装完后没有找到自动运行脚本。。是不是系统不支持啊。

        • Google Chrome 55.0.2859.0Google Chrome 55.0.2859.0Windows 10 x64Windows 10 x64

          看了看服务启动文件,发现是作者的文件有点问题,你可以打开 /etc/init.d/v2ray
          将第29行修改为:

发表回复

你的邮箱地址不会被公开,垃圾评论将被删除。

有人回复时邮件通知我